# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)\s(Yanvar|Fevral|Mart|Aprel|May|İyun|İyul|Avqust|Sentyabr|Oktyabr|Noyabr|Dekabr)"
test_str = ("1 Yanvar\n"
"2 Fevral\n"
"3 Mart\n"
"4 Aprel\n"
"5 May\n"
"6 İyun\n"
"7 İyul\n"
"8 Avqust\n"
"9 Sentyabr\n"
"10 Oktyabr\n"
"11 Noyabr\n"
"12 Dekabr")
subst = "$1 \\L$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.