import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\d{11})|((\\d{3}[-.\\/]){3}\\d{2}))$";
final String string = "/*https://www.geradordecpf.org/*/\n"
+ "784.267.866-93\n"
+ "087.465.490-48\n"
+ "747.507.895-77\n"
+ "55465881798\n"
+ "554.658.817-98\n"
+ "554.AA9.817-98\n"
+ "554.658.817/98\n"
+ "554-658.817/98\n"
+ "577 333 506 97\n"
+ "78913560178";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}