const regex = /^((\d{11})|((\d{3}[-.\/]){3}\d{2}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\d{11})|((\\d{3}[-.\\\/]){3}\\d{2}))$', 'gm')
const str = `/*https://www.geradordecpf.org/*/
784.267.866-93
087.465.490-48
747.507.895-77
55465881798
554.658.817-98
554.AA9.817-98
554.658.817/98
554-658.817/98
577 333 506 97
78913560178`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}