import re
regex = re.compile(r"^((\d{11})|((\d{3}[-.\/]){3}\d{2}))$", flags=re.MULTILINE)
test_str = ("/*https://www.geradordecpf.org/*/\n"
"784.267.866-93\n"
"087.465.490-48\n"
"747.507.895-77\n"
"55465881798\n"
"554.658.817-98\n"
"554.AA9.817-98\n"
"554.658.817/98\n"
"554-658.817/98\n"
"577 333 506 97\n"
"78913560178")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")