#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^A-Za-z\n]*[A-Za-z].*$"
Local $sString = "alpha" & @CRLF & _
"Alpha1" & @CRLF & _
"A35. 1ha" & @CRLF & _
"Alp1Ha" & @CRLF & _
"A pha6" & @CRLF & _
"" & @CRLF & _
"12345" & @CRLF & _
"0" & @CRLF & _
"-23442"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")