// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^A-Za-z\n]*[A-Za-z].*$").unwrap();
let string = "alpha
Alpha1
A35. 1ha
Alp1Ha
A pha6
12345
0
-23442";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}