package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^A-Za-z\n]*[A-Za-z].*$`)
var str = `alpha
Alpha1
A35. 1ha
Alp1Ha
A pha6
12345
0
-23442`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}