using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^A-Za-z\n]*[A-Za-z].*$";
string input = @"alpha
Alpha1
A35. 1ha
Alp1Ha
A pha6
12345
0
-23442";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}