re = /^[^A-Za-z\n]*[A-Za-z].*$/m
str = 'alpha
Alpha1
A35. 1ha
Alp1Ha
A pha6
12345
0
-23442'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end