import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^A-Za-z\\n]*[A-Za-z].*$";
final String string = "alpha\n"
+ "Alpha1\n"
+ "A35. 1ha\n"
+ "Alp1Ha\n"
+ "A pha6\n\n"
+ "12345\n"
+ "0\n"
+ "-23442";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}