#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\b"
Local $sString = "02:33" & @CRLF & _
"2:33" & @CRLF & _
"12:22:32" & @CRLF & _
"The time is 23:33" & @CRLF & _
"it's12:34" & @CRLF & _
"12:33:34455" & @CRLF & _
"44:45" & @CRLF & _
"25:50:02" & @CRLF & _
"18:78" & @CRLF & _
"2A:3E:EE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")