re = /\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\b/m
str = '02:33
2:33
12:22:32
The time is 23:33
it\'s12:34
12:33:34455
44:45
25:50:02
18:78
2A:3E:EE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end