using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\b";
string input = @"02:33
2:33
12:22:32
The time is 23:33
it's12:34
12:33:34455
44:45
25:50:02
18:78
2A:3E:EE
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}