import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\\b";
final String string = "02:33\n"
+ "2:33\n"
+ "12:22:32\n"
+ "The time is 23:33\n"
+ "it's12:34\n"
+ "12:33:34455\n"
+ "44:45\n"
+ "25:50:02\n"
+ "18:78\n"
+ "2A:3E:EE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}