const regex = new RegExp('\\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\\b', 'gm')
const str = `02:33
2:33
12:22:32
The time is 23:33
it's12:34
12:33:34455
44:45
25:50:02
18:78
2A:3E:EE
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}