#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)(^([a-z0-9]){1}[a-z0-9_.?]+)$"
Local $sString = "myproject" & @CRLF & _
"myproject123" & @CRLF & _
"123myproject" & @CRLF & _
"test_1" & @CRLF & _
"test.vn.ne233" & @CRLF & _
"t_f" & @CRLF & _
"" & @CRLF & _
"MyProject" & @CRLF & _
".test" & @CRLF & _
"_check999" & @CRLF & _
"999999" & @CRLF & _
"!myproject" & @CRLF & _
"^jejej" & @CRLF & _
"efefef!" & @CRLF & _
"&jfjjf" & @CRLF & _
"myproject 123" & @CRLF & _
"....."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")