import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([a-z0-9]){1}[a-z0-9_.?]+)$";
final String string = "myproject\n"
+ "myproject123\n"
+ "123myproject\n"
+ "test_1\n"
+ "test.vn.ne233\n"
+ "t_f\n\n"
+ "MyProject\n"
+ ".test\n"
+ "_check999\n"
+ "999999\n"
+ "!myproject\n"
+ "^jejej\n"
+ "efefef!\n"
+ "&jfjjf\n"
+ "myproject 123\n"
+ ".....";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}