// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)(^([a-z0-9]){1}[a-z0-9_.?]+)$").unwrap();
let string = "myproject
myproject123
123myproject
test_1
test.vn.ne233
t_f
MyProject
.test
_check999
999999
!myproject
^jejej
efefef!
&jfjjf
myproject 123
.....";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}