package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^([a-z0-9]){1}[a-z0-9_.?]+)$`)
var str = `myproject
myproject123
123myproject
test_1
test.vn.ne233
t_f
MyProject
.test
_check999
999999
!myproject
^jejej
efefef!
&jfjjf
myproject 123
.....`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}