$re = '/(^([a-z0-9]){1}[a-z0-9_.?]+)$/um';
$str = 'myproject
myproject123
123myproject
test_1
test.vn.ne233
t_f
MyProject
.test
_check999
999999
!myproject
^jejej
efefef!
&jfjjf
myproject 123
.....';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);