use strict;
my $str = 'myproject
myproject123
123myproject
test_1
test.vn.ne233
t_f
MyProject
.test
_check999
999999
!myproject
^jejej
efefef!
&jfjjf
myproject 123
.....';
my $regex = qr/(^([a-z0-9]){1}[a-z0-9_.?]+)$/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}