using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^([a-z0-9]){1}[a-z0-9_.?]+)$";
string input = @"myproject
myproject123
123myproject
test_1
test.vn.ne233
t_f
MyProject
.test
_check999
999999
!myproject
^jejej
efefef!
&jfjjf
myproject 123
.....";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}