const regex = /^(?:(?:[12]\d|3[01]|[1-9]),?\b)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[12]\\d|3[01]|[1-9]),?\\b)+$', 'gm')
const str = `1,22,31
A
31,33,33
2,,
1,2.,3%
0,1,2,3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}