$re = '/^(?:(?:[12]\d|3[01]|[1-9]),?\b)+$/m';
$str = '1,22,31
A
31,33,33
2,,
1,2.,3%
0,1,2,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);