// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:[12]\d|3[01]|[1-9]),?\b)+$").unwrap();
let string = "1,22,31
A
31,33,33
2,,
1,2.,3%
0,1,2,3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}