re = /^(?:(?:[12]\d|3[01]|[1-9]),?\b)+$/m
str = '1,22,31
A
31,33,33
2,,
1,2.,3%
0,1,2,3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end