import re
regex = re.compile(r"^(?:(?:[12]\d|3[01]|[1-9]),?\b)+$", flags=re.MULTILINE)
test_str = ("1,22,31\n"
"A\n"
"31,33,33\n"
"2,,\n"
"1,2.,3%\n"
"0,1,2,3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")