#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)this_one_is_bad@whatever\.com|alsothisone@gmail\.com"
Local $sString = "someemail@gmail.com" & @CRLF & _
"another@outlook.com" & @CRLF & _
"this_one_is_bad@whatever.com" & @CRLF & _
"alsothisone@gmail.com" & @CRLF & _
"butnotthisone@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")