import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "this_one_is_bad@whatever\\.com|alsothisone@gmail\\.com";
final String string = "someemail@gmail.com\n"
+ "another@outlook.com\n"
+ "this_one_is_bad@whatever.com\n"
+ "alsothisone@gmail.com\n"
+ "butnotthisone@gmail.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}