using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"this_one_is_bad@whatever\.com|alsothisone@gmail\.com";
string input = @"someemail@gmail.com
another@outlook.com
this_one_is_bad@whatever.com
alsothisone@gmail.com
butnotthisone@gmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}