package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)this_one_is_bad@whatever\.com|alsothisone@gmail\.com`)
var str = `someemail@gmail.com
another@outlook.com
this_one_is_bad@whatever.com
alsothisone@gmail.com
butnotthisone@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}