const regex = /this_one_is_bad@whatever\.com|alsothisone@gmail\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('this_one_is_bad@whatever\\.com|alsothisone@gmail\\.com', 'gm')
const str = `someemail@gmail.com
another@outlook.com
this_one_is_bad@whatever.com
alsothisone@gmail.com
butnotthisone@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}