re = /this_one_is_bad@whatever\.com|alsothisone@gmail\.com/m
str = 'someemail@gmail.com
another@outlook.com
this_one_is_bad@whatever.com
alsothisone@gmail.com
butnotthisone@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end