$re = '/this_one_is_bad@whatever\.com|alsothisone@gmail\.com/m';
$str = 'someemail@gmail.com
another@outlook.com
this_one_is_bad@whatever.com
alsothisone@gmail.com
butnotthisone@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);