using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^m]>";
string substitution = @"";
string input = @"<test@gmail.com>
>Lorem ipsum dolor sit amet,<test@gmail.com> consectetur
>adipiscing elit. Integer nec >
>odio. Praesent libero. Sed cursus ante dapibus diam. Sed nisi. Nulla
>quis sem at nibh elementum imperdiet.Duis sagittis ipsum. Praesent
>mauris. Fusce nec tellus sed augue semper porta. Mauris massa.
>Vestibulum lacinia arcu eget nulla. Class aptent taciti sociosqu.
<test@gmail.com>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}