import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^m]>";
final String string = "<test@gmail.com>\n"
+ " >Lorem ipsum dolor sit amet,<test@gmail.com> consectetur\n"
+ " >adipiscing elit. Integer nec >\n"
+ " >odio. Praesent libero. Sed cursus ante dapibus diam. Sed nisi. Nulla \n"
+ " >quis sem at nibh elementum imperdiet.Duis sagittis ipsum. Praesent \n"
+ " >mauris. Fusce nec tellus sed augue semper porta. Mauris massa. \n"
+ " >Vestibulum lacinia arcu eget nulla. Class aptent taciti sociosqu. \n"
+ " <test@gmail.com>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}