# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^m]>"
test_str = ("<test@gmail.com>\n"
" >Lorem ipsum dolor sit amet,<test@gmail.com> consectetur\n"
" >adipiscing elit. Integer nec >\n"
" >odio. Praesent libero. Sed cursus ante dapibus diam. Sed nisi. Nulla \n"
" >quis sem at nibh elementum imperdiet.Duis sagittis ipsum. Praesent \n"
" >mauris. Fusce nec tellus sed augue semper porta. Mauris massa. \n"
" >Vestibulum lacinia arcu eget nulla. Class aptent taciti sociosqu. \n"
" <test@gmail.com>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.