import Foundation
let pattern = #"[^m]>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<test@gmail.com>
>Lorem ipsum dolor sit amet,<test@gmail.com> consectetur
>adipiscing elit. Integer nec >
>odio. Praesent libero. Sed cursus ante dapibus diam. Sed nisi. Nulla
>quis sem at nibh elementum imperdiet.Duis sagittis ipsum. Praesent
>mauris. Fusce nec tellus sed augue semper porta. Mauris massa.
>Vestibulum lacinia arcu eget nulla. Class aptent taciti sociosqu.
<test@gmail.com>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)