// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^m]>").unwrap();
let string = "<test@gmail.com>
>Lorem ipsum dolor sit amet,<test@gmail.com> consectetur
>adipiscing elit. Integer nec >
>odio. Praesent libero. Sed cursus ante dapibus diam. Sed nisi. Nulla
>quis sem at nibh elementum imperdiet.Duis sagittis ipsum. Praesent
>mauris. Fusce nec tellus sed augue semper porta. Mauris massa.
>Vestibulum lacinia arcu eget nulla. Class aptent taciti sociosqu.
<test@gmail.com>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}