import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "payload:\\\\\"(.+?)\\\\\\\\\\\\\"\\\\\\\\";
final String string = "version:1 response:<status:200 message:\\\"OK\\\" payload:\\\"{\\\\\\\"id\\\\\\\":\\\\\\\"ll2.card_4U45pAWUMCLhsu\\\\\\\",\\\\\\\"uid\\\\\\\":\\\\\\\"ll2.acc_727V8M6GjPJ9I26CqZHgxN\\\\\\\"}\\\\\\\"\\\\013\\\\022\\\\006ll2-cc\\\\032\\\\0019\\\" endorsement:<endorser:\\\"\\\\n\\\\007PASSKIT\\\\022\\\\224\\\\010>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}