const regex = /payload:\\"(.+?)\\\\\\"\\\\/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('payload:\\\\"(.+?)\\\\\\\\\\\\"\\\\\\\\', 'g')
const str = `version:1 response:<status:200 message:\\"OK\\" payload:\\"{\\\\\\"id\\\\\\":\\\\\\"ll2.card_4U45pAWUMCLhsu\\\\\\",\\\\\\"uid\\\\\\":\\\\\\"ll2.acc_727V8M6GjPJ9I26CqZHgxN\\\\\\"}\\\\\\"\\\\013\\\\022\\\\006ll2-cc\\\\032\\\\0019\\" endorsement:<endorser:\\"\\\\n\\\\007PASSKIT\\\\022\\\\224\\\\010>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}