import Foundation
let pattern = #"payload:\\"(.+?)\\\\\\"\\\\"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"version:1 response:<status:200 message:\"OK\" payload:\"{\\\"id\\\":\\\"ll2.card_4U45pAWUMCLhsu\\\",\\\"uid\\\":\\\"ll2.acc_727V8M6GjPJ9I26CqZHgxN\\\"}\\\"\\013\\022\\006ll2-cc\\032\\0019\" endorsement:<endorser:\"\\n\\007PASSKIT\\022\\224\\010>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)