use strict;
my $str = 'version:1 response:<status:200 message:\\"OK\\" payload:\\"{\\\\\\"id\\\\\\":\\\\\\"ll2.card_4U45pAWUMCLhsu\\\\\\",\\\\\\"uid\\\\\\":\\\\\\"ll2.acc_727V8M6GjPJ9I26CqZHgxN\\\\\\"}\\\\\\"\\\\013\\\\022\\\\006ll2-cc\\\\032\\\\0019\\" endorsement:<endorser:\\"\\\\n\\\\007PASSKIT\\\\022\\\\224\\\\010>';
my $regex = qr/payload:\\"(.+?)\\\\\\"\\\\/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}