// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"payload:\\"(.+?)\\\\\\"\\\\"#).unwrap();
let string = "version:1 response:<status:200 message:\\\"OK\\\" payload:\\\"{\\\\\\\"id\\\\\\\":\\\\\\\"ll2.card_4U45pAWUMCLhsu\\\\\\\",\\\\\\\"uid\\\\\\\":\\\\\\\"ll2.acc_727V8M6GjPJ9I26CqZHgxN\\\\\\\"}\\\\\\\"\\\\013\\\\022\\\\006ll2-cc\\\\032\\\\0019\\\" endorsement:<endorser:\\\"\\\\n\\\\007PASSKIT\\\\022\\\\224\\\\010>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}