#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)MLFTLGH[a-zA-Z0-9]{8}"
Local $sString = "Hi," & @CRLF & _
"" & @CRLF & _
"I have a requirement where I have to extract the required string like "MLFTLGH105456IV!" from a total string." & @CRLF & _
"" & @CRLF & _
"The required string is fixed in length and will always start with MLFTLGH followed by 8 alpha numerical characters in random with no space in between as in above format but can appear anywhere within the total string like at the beginning of total string, middle of total string or at the last of total string." & @CRLF & _
"" & @CRLF & _
"Some more required string examples - MLFTLGH10545001, MLFTLGH105456GH, MLFTLGH1054565D, MLFTLGH100542TH" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Please suggest how to extract the required string."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")