const regex = /MLFTLGH[a-zA-Z0-9]{8}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('MLFTLGH[a-zA-Z0-9]{8}', 'gm')
const str = `Hi,
I have a requirement where I have to extract the required string like "MLFTLGH105456IV!" from a total string.
The required string is fixed in length and will always start with MLFTLGH followed by 8 alpha numerical characters in random with no space in between as in above format but can appear anywhere within the total string like at the beginning of total string, middle of total string or at the last of total string.
Some more required string examples - MLFTLGH10545001, MLFTLGH105456GH, MLFTLGH1054565D, MLFTLGH100542TH
Please suggest how to extract the required string.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}