use strict;
my $str = 'Hi,
I have a requirement where I have to extract the required string like "MLFTLGH105456IV!" from a total string.
The required string is fixed in length and will always start with MLFTLGH followed by 8 alpha numerical characters in random with no space in between as in above format but can appear anywhere within the total string like at the beginning of total string, middle of total string or at the last of total string.
Some more required string examples - MLFTLGH10545001, MLFTLGH105456GH, MLFTLGH1054565D, MLFTLGH100542TH
Please suggest how to extract the required string.';
my $regex = qr/MLFTLGH[a-zA-Z0-9]{8}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}