// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)MLFTLGH[a-zA-Z0-9]{8}").unwrap();
let string = "Hi,
I have a requirement where I have to extract the required string like \"MLFTLGH105456IV!\" from a total string.
The required string is fixed in length and will always start with MLFTLGH followed by 8 alpha numerical characters in random with no space in between as in above format but can appear anywhere within the total string like at the beginning of total string, middle of total string or at the last of total string.
Some more required string examples - MLFTLGH10545001, MLFTLGH105456GH, MLFTLGH1054565D, MLFTLGH100542TH
Please suggest how to extract the required string.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}