import Foundation
let pattern = #"MLFTLGH[a-zA-Z0-9]{8}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hi,
I have a requirement where I have to extract the required string like "MLFTLGH105456IV!" from a total string.
The required string is fixed in length and will always start with MLFTLGH followed by 8 alpha numerical characters in random with no space in between as in above format but can appear anywhere within the total string like at the beginning of total string, middle of total string or at the last of total string.
Some more required string examples - MLFTLGH10545001, MLFTLGH105456GH, MLFTLGH1054565D, MLFTLGH100542TH
Please suggest how to extract the required string.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)