$re = '/MLFTLGH[a-zA-Z0-9]{8}/m';
$str = 'Hi,
I have a requirement where I have to extract the required string like "MLFTLGH105456IV!" from a total string.
The required string is fixed in length and will always start with MLFTLGH followed by 8 alpha numerical characters in random with no space in between as in above format but can appear anywhere within the total string like at the beginning of total string, middle of total string or at the last of total string.
Some more required string examples - MLFTLGH10545001, MLFTLGH105456GH, MLFTLGH1054565D, MLFTLGH100542TH
Please suggest how to extract the required string.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);